Sony pulls another PSP game for allowing homebrew on Vita

Hops to it.

Sony's pulled another vulnerable PSP game, Super Collapse, from the PlayStation Store. It allowed an unauthorised program to run homebrew software on PlayStation Vita.

homebrew

The unauthorised program is the Vita Half-Byte Loader by Wololo. It's an open source homebrew loader that enables fan-made games and applications to run on PSP (up to firmware 6.60) and Vita (up to firmware 1.67). It also allows emulators for Game Boy, N64, Mega Drive, NES and SNES.

It does not, however, allow pirated PSP or Vita games to be played, according to the maker's disclaimer.

"Most likely, if you didn't buy the vulnerable game(s) in time, you will not be able to run VHBL. But we are regularly bringing more exploits to VHBL, so stay tuned on this page for further updates."

Wololo, maker, Vita Half-Byte Loader

"It is super easy for Sony to patch the vulnerabilities used by this tool, given the amount of control they have on the PS Vita," Wololo's Vita Half-Byte Loader page reads. "Depending on your game, VHBL runs fine on firmware 1.67, but for all I know it is possible for Sony to patch the game's vulnerability without a firmware update. So, once again, before buying the game and downloading VHBL, you need to understand that you pay for the game, and VHBL is a bonus that might or might not work.

"Sony's strategy so far has been to remove these games from their Store, and put them back once the Vita firmware is patched. Most likely, if you didn't buy the vulnerable game(s) in time, you will not be able to run VHBL. But we are regularly bringing more exploits to VHBL, so stay tuned on this page for further updates."

PSP games MotorStorm: Arctic Edge and and Everybody's Tennis were pulled from the PlayStation Store earlier this year for the same reason. And then returned.

But Wololo and gang don't like reports such as this one that draw Sony's eye to vulnerable PSP games, because they inevitably lead to a fix. The plan for next time, it seems, is to tell only Wololo forum members about a new VHBL-vulnerable PSP title.

Sony hasn't commented on Super Collapse's removal.

Comments (22)

Comments for this article are now closed, but please feel free to continue chatting on the forum!