Sony has released a special Halloween LocoRoco demo along with a new firmware update for PSP, the latter of which brings the system up to version 2.82.

So what does 2.82 do? And do you need it? Well, according to the release notes, it adds all sorts of extras, but actually those are just the bits that changed in 2.80 and 2.81 - all it really does is install some new security measures.

What's more, you don't actually need it to play the LocoRoco demo, despite the proximity of the two releases. Providing your PSP has version 2.71 firmware or later, the demo should work. Hurrah!

Still interested? Then European gamers can download the 2.82 firmware from YourPSP.com, or you could use the US version or the PSP's onboard software.

Meanwhile, the LocoRoco Halloween demo level, which you don't need a copy of the game to play, is available in US and European flavours.

Sometimes we include links to online retail stores. If you click on one and make a purchase we may receive a small commission. For more information, go here.

Jump to comments (38)

About the author

Tom Bramwell

Tom Bramwell

Contributor

Tom worked at Eurogamer from early 2000 to late 2014, including seven years as Editor-in-Chief.

More articles by Tom Bramwell

Comments (38)

Hide low-scoring comments
Order
Threading

Related

LocoRoco

Roc 'n' roll star.

More evidence of LocoRoco 2 emerges

Looks like it could be on show next week.

LocoRoco PS3 dated

In Japan, anyway.

LocoRoco creator talks racism

Likes black ones the most.

LocoRoco man on PSP line-up

"There are too many sequels".