problem getting playstation 3 to work on Hitachi 32LD6200 TV

  • Page

    of 1

    Previous Next
  • martinward 27 Mar 2013 04:23:30 1 posts
    Seen 1 year ago
    Registered 1 year ago
    I have a Hitachi 32LD6200 TV and I am trying to connect my PS3 to it. I have connected the 3 coloured cables into the ports provided on the side and have been through all of the AV channels and I still get no picture.
    I know it's not a problem with the PS3 I have tried on other TV's and it works.
    Am I doing something wrong or have I missed something completely?
  • PazJohnMitch 27 Mar 2013 05:03:36 7,729 posts
    Seen 2 hours ago
    Registered 7 years ago
    http://www.eurogamer.net/forum/thread/100335
  • Dangerous_Dan 27 Mar 2013 05:08:18 2,372 posts
    Seen 53 minutes ago
    Registered 4 years ago
    martinward wrote:
    I have a Hitachi 32LD6200 TV and I am trying to connect my PS3 to it. I have connected the 3 coloured cables into the ports provided on the side and have been through all of the AV channels and I still get no picture.
    I know it's not a problem with the PS3 I have tried on other TV's and it works.
    Am I doing something wrong or have I missed something completely?
    With 3 cables you mean the yellow one and a red one and a white one?

    Yellow - Composite Video
    Red n White - Audio

    Try pressing down the power button on the PS3 until it beeps (takes a few seconds). Then it should be set into a video safety mode. If the PS3 and your TV work properly then you should find it on some AV channel or something.
  • Page

    of 1

    Previous Next
Log in or register to reply