Steam window focus problem (Windows 7)

  • Page

    of 1

    Previous Next
  • One_Vurfed_Gwrx 29 Jan 2013 14:43:33 534 posts
    Seen 5 hours ago
    Registered 8 years ago
    I hope this is the right place for this question. I have tried googling solutions to my problem but can only seem to find Linux related issues with my search terms.

    I have ran Steam without problems for a long time, but relatively recently (not sure when or any changes made to cause the problem) any game I play on Steam will switch to Windows or minimise the game application approximately every 10 or 15 minutes. With most games this is an annoyance (pausing the game, or keeping the game running without pausing it), but some games will crash when this happens (Super Meat Boy). This problem seems to happen with every game I play using Steam, from Indie titles to AAA titles from varying publishers.

    I've fiddled somewhat but can't seem to find any solution to this extremely annoying problem so any help would be appreciated. I am running on Windows 7 Ultimate 64 (and as far as I know this problem is not occurring with non Steam games, but maybe I should give one a good try when I get the chance). I doubt my hardware matters, but I am running a G77 Mobo with an i5 and a GT670 OC with 8GB of system RAM). Nothing appears to be popping up in Windows to activate teh switch either.
  • kickerconspiracy 29 Jan 2013 14:49:43 495 posts
    Seen 1 year ago
    Registered 7 years ago
    Added any new hardware lately?

    I saw on a forum where someone said something about adding a wireless adaptor and that causing a similar issue.
  • BeheretiK 29 Jan 2013 14:57:45 883 posts
    Seen 8 hours ago
    Registered 8 years ago
    I had the exact same issue and also thought it was something to do with Steam. Turned out to be Citrix Receiver which I had used as part of work. I wasn't really aware at the time that it had created a startup process - only after going through all programs in an attempt to find the focus issue did I come across it. Removing that fixed the problem for me...

    Obviously in your case it is maybe not Citrix but point is, it could be any other program that you installed recently. Check them all!

    3DS: 5241-1899-2292

  • THFourteen 29 Jan 2013 15:20:02 32,868 posts
    Seen 4 minutes ago
    Registered 9 years ago
    Motherless fucks

    Been having this issue for a while in windows 8

    And I DO have Citrix installed!
  • One_Vurfed_Gwrx 30 Jan 2013 09:21:23 534 posts
    Seen 5 hours ago
    Registered 8 years ago
    No, new hardware, built this system from scratch and it worked fine for months. I have thought about it being other software but I shouldn't have installed anything that could take control. It's an annoying problem and I can't think of too many possible solutions except a reinstall of Windows which sounds like overkill... I will try and play something on Origin for a while and see if the problem exists outside of Steam (or a retail CD, alhough I don't have many options there)

    EDIT - And just to confuse me more, I just managed to play 80 minutes of Hitman Absolution without any issues...

    Edited by One_Vurfed_Gwrx at 13:02:56 30-01-2013
  • One_Vurfed_Gwrx 30 Jan 2013 14:16:31 534 posts
    Seen 5 hours ago
    Registered 8 years ago
    And it seems the problem is not just in Steam, tried Dead Rising OTR (retail copy) and had same problem (with some bizarre glitches from screen switching making invisible objects appear). Tried closing my browser, no luck, not sure what to "kill" next... Nothing obvious pops up when the window switches either.
  • Page

    of 1

    Previous Next
Log in or register to reply