#8252462, By DanC89 The Elder Scrolls V: Skyrim

  • DanC89 12 Dec 2011 23:28:33 267 posts
    Seen 1 year ago
    Registered 8 years ago
    Bulbatron wrote:
    Well, that's it, I'm completely stuck now. Been doing the main quest, and I've just finished "Diplomatic Immunity" (where you have to go to the party at the Thalmor Embassy). Unfortunately, the next part of the main quest will not activate, leaving me, as I say, stuck.

    I've spoken to Delphene and she's told me to look for Esbern in the Ratways and to ask around in the Ragged Flagon - and easy task since I've completely finished the Thieves Guild quest-line. However, I cannot get any new dialogue out of anybody at this location, so I cannot progress any further in the quest. The worst thing is, I've actually found Esbern on my own, but since I can't get the quest to activate, he won't say anything specific to me which relates to the quest.

    I don't know whether the next part of the quest is supposed to activate as soon as Delphine has finished talking at the end of "Diplomatic Immunity" or not until you've spoken to somebody about him at the Ragged Flagon, but either way, I can't get anything else to happen.


    I've tried re-loading from an earlier save, but it didn't help.

    I've spoken to my brother about this and the quest worked fine for him, no problems. My brother and I both have the Xbox 360 version, and both have the new slim machines.

    I appear to have two choice. Start again and hope the same thing doesn't happen, or wait for Bethesda to (hopefully) fix this quest.
    I had exactly the same issue on the PS3 version.
Log in or register to reply