#8650307, By George-Roper Guild Wars 2

  • George-Roper 30 Apr 2012 14:07:51 704 posts
    Seen 7 minutes ago
    Registered 10 years ago
    rodpad wrote:
    Put settings on maximum and you get 100% GPU usage in high framerate areas, as expected and desired. Pop on Vsync and of course usage goes down in low complexity areas. I'm using an MSI Frozr II GTX 560 Ti.

    The GPU is being used correctly but the CPU isn't, hence the ~25% usage in task manager.
    Not wanting to be confrontational (for once) but that's wrong. The GPU is being 'used' but only for the basic rendering, nothing more.

    You're right that the game is CPU bound and to seemingly one core but GPUs are not being properly utilized yet, so playing on a 680 or a 570 is the same, choppy experience.

    Taken from their Tech Support forum...

    Display: the graphics-settings slider has only a minor impact on performance at this time.

    We are currently optimizing Guild Wars 2, making ongoing improvements to the gameís frame rate. Presently, the game is CPU-bound on most high-end systems, so lowering graphics settings or upgrading your video card may not have a large impact on performance.


    The interesting point about this though is that section where they say "most high-end systems". That's why I was wondering what GPU you had.

    In my case, the GPU (Nvidia 590 in single card mode) didn't get pushed in any way across all my game time, on max settings. From being in the tutorials and starting areas (with masses of players) and even cities. All the way through, the GPU essentially ran at just over idle temps, regardless of on-screen action, whereas typical other gaming sees me hit upper 70's, lower 80's (the latter on BF3).

    I'm trusting they'll sort all of this in the up and coming Betas (one per month until release, I believe), because it's a gorgeous looking game and deserves to have all the graphical fidelity maxed out and running silky smooth to truly appreciate everything.
Log in or register to reply