#6417857, By Jackface iPods for iDiots

  • Jackface 1 Aug 2010 16:08:32 3,736 posts
    Seen 4 years ago
    Registered 5 years ago
    DDevil wrote:
    Well I'm not all that bothered. It still runs fine for the most part, I doubt I would have noticed if it wasn't for the wallpaper thing.

    Jackface wrote:
    Every app in the store says next to it what devices and OS it requires, but yes older devices that technically run some apps don't do so very well at all.

    All it says on the app store is something like (for example) "Compatible with iPhone, iPod Touch and iPad. Requires iOS 2.2.1 or later." That's on Earthworm Jim, which is one of the games that just quits out when you try to run it. No mention of specific models.
    Ohhh.

    When I had a 3G that was getting old I used to take note of the reviews at places like Touch Arcade that mentioned what the performance was like on older models.
Log in or register to reply