<!DOCTYPE HTML>
<html xml:lang="en" lang="en" xmlns:fb="http://www.facebook.com/2008/fbml">
	<head>
	<!--
	   ______                             _   __     __                      __  
	  / ____/___ _____ ___  ___  _____   / | / /__  / /__      ______  _____/ /__
	 / / __/ __ `/ __ `__ \/ _ \/ ___/  /  |/ / _ \/ __/ | /| / / __ \/ ___/ //_/
	/ /_/ / /_/ / / / / / /  __/ /     / /|  /  __/ /_ | |/ |/ / /_/ / /  / ,<   
	\____/\__,_/_/ /_/ /_/\___/_/     /_/ |_/\___/\__/ |__/|__/\____/_/  /_/|_|  
                                                             
	Copyright 2017. All rights reserved.

	We're hiring!
	See: http://www.gamer-network.net/about/jobs-and-internships
	-->

				<base href="http://www.eurogamer.net/" />
				<title>Unreal Engine now fully supports Nintendo Switch development &bull; Eurogamer.net</title>
				<meta http-equiv="X-UA-Compatible" content="IE=edge" />
				
					<link rel="canonical" href="http://www.eurogamer.net/articles/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development" />
								
		<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/Icons.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/tools.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/base.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/hd/hd.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/pager.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/net.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/Components/related-games.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/Components/recommendations.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/discussable.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/comments.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/hd/comments.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/hd/discussable.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/article.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/hd/article.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/InlineGallery.css?v20170523155005" media="screen" />
<link rel="stylesheet" type="text/css" href="/styles/Eurogamer/Components/in-article-promos.css?v20170523155005" media="screen" />
				<meta name="twitter:card" content="summary_large_image" />
							<meta name="twitter:site" content="@eurogamer" />
							<meta name="twitter:title" content="Unreal Engine now fully supports Nintendo Switch development" />
							<meta name="twitter:url" content="http://www.eurogamer.net/articles/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development" />
							<meta name="twitter:description" content="Epic has teamed up with Nintendo to offer &quot;fully-featured&quot; Unreal Engine support to approved developers for free.
  
  
    
  
  
 
The previous version of&amp;hellip;" />
							<meta name="twitter:image:src" content="http://images.eurogamer.net/2017/articles/1/9/0/2/5/6/2/unreal-engine-now-fully-supports-nintendo-switch-development-1495641324482.jpg/EG11/thumbnail/1200x630/format/jpg/1902562.jpg" />
							<meta property="og:site_name" content="Eurogamer.net" />
							<meta property="fb:app_id" content="156247124404264" />
							<meta property="fb:pages" content="42657691753" />
							<meta property="og:title" content="Unreal Engine now fully supports Nintendo Switch development" />
							<meta property="og:url" content="http://www.eurogamer.net/articles/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development" />
							<meta property="og:type" content="article" />
							<meta property="og:image:width" content="1200" />
							<meta property="og:image:height" content="630" />
							<meta property="og:image" content="http://images.eurogamer.net/2017/articles/1/9/0/2/5/6/2/unreal-engine-now-fully-supports-nintendo-switch-development-1495641324482.jpg/EG11/thumbnail/1200x630/format/jpg/1902562.jpg" />
							<meta property="og:description" content="Epic has teamed up with Nintendo to offer &quot;fully-featured&quot; Unreal Engine support to approved developers for free.
  
  
    
  
  
 
The previous version of&amp;hellip;" />
							<meta name="description" content="Epic has teamed up with Nintendo to offer &quot;fully-featured&quot; Unreal Engine support to approved developers for free.
  
  
    
  
  
 
The previous version of&amp;hellip;" />
						<link rel="apple-touch-icon" href="img/EurogamerPage/apple-touch-icon.png"/>
					<link rel="shortcut icon" href="http://www.eurogamer.net/favicon.ico" />
				
					<link rel="feed" title="RSS" href="http://www.eurogamer.net/?format=rss"/>
		
		<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>
<script>var j = jQuery.noConflict();</script><script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.2/jquery-ui.min.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/prototype/1.7.1.0/prototype.js"></script>
<script src="//ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js"></script>
<script src="/scripts/Eurogamer/Eurogamer.js?v20170523155005"></script>
<script src="/scripts/Eurogamer/Countdown.js?v20170523155005"></script>
<script src="//cdn.gamer-network.net/plugins/dfp/jquery.jsonp.2.4.0.js"></script>
<script src="//cdn.gamer-network.net/plugins/dfp/async.dfp.1.1.16.js"></script>
<script src="/scripts/Eurogamer/Autogrow.js?v20170523155005"></script>
<script src="/scripts/Eurogamer/Comments.js?v20170523155005"></script>
<script src="/scripts/Eurogamer/Popup.js?v20170523155005"></script>
<script src="/scripts/Video.js?v20170523155005"></script>
<script src="/scripts/Eurogamer/Toolbar.js?v20170523155005"></script>
<script src="/scripts/Eurogamer/InlineGallery.js?v20170523155005"></script>
<script src="/scripts/Eurogamer/SocialButtons.js?v20170523155005"></script>
<!--[if lt IE 9]>
<script>
document.createElement('header');
document.createElement('nav');
document.createElement('section');
document.createElement('article');
document.createElement('aside');
document.createElement('footer');
</script>
<![endif]-->
<link rel="amphtml" href="//www.eurogamer.net/amp/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development" />

				<script type='text/javascript'>
					var _sf_async_config = _sf_async_config || {};
					_sf_async_config.uid = 63584;
					_sf_async_config.domain = 'eurogamer.net';
					_sf_async_config.flickerControl = false;
					_sf_async_config.useCanonical = true;
					var _sf_startpt = (new Date()).getTime();
				</script>
				<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>
				

				<script>
					(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
					(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
					m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
					})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
					ga('create', 'UA-12091157-1', '.eurogamer.net');
					ga('require', 'displayfeatures');
					ga('require', 'linkid', 'linkid.js');
			
					ga('set', 'dimension1', 'news');
				
					ga('set', 'dimension3', 'SWITCH');
				
					ga('set', 'dimension4', 'Jeffrey Matulef');
				
					ga('set', 'dimension5', '0');
				
					ga('set', 'dimension7', 'hd');
				
					ga('send', 'pageview');
				</script>
			
	</head>
		<body id="theTop">		
		
				<div id="fb-root"></div>
		<script>
			window.fbAsyncInit = function () {
				FB.init({
					appId: '156247124404264',
					version: 'v2.7',
					channelUrl: '/channel.html',
					status: true,
					cookie: true,
					xfbml: true,
					oauth: true
				});

				// Push likes to Google Analytics
				FB.Event.subscribe('edge.create', function (targetUrl) {
					ga('send', 'social', 'facebook', 'like', targetUrl);
				});
			};

			// Load the SDK Asynchronously
			(function (d) {
				var js, id = 'facebook-jssdk', ref = d.getElementsByTagName('script')[0];
				if (d.getElementById(id)) {
					return;
				}
				js = d.createElement('script');
				js.id = id;
				js.async = true;

								js.src = "//connect.facebook.net/en_GB/all.js";
				ref.parentNode.insertBefore(js, ref);
			}(document));
		</script>

		<script type='text/javascript'>var _ox_zones = new Array();_ox_zones[ 'video-preroll-hd' ] = '';</script>
		<div id="browserMaster" class="hd">

						
						
			
			<div id="header">

				<div id="header-content">
					<a href="http://www.eurogamer.net/" id="logo">
						<img
								src="/img/EurogamerPage/logo/hd/net.png?v20170523155005"
								alt="Video game reviews, news, previews, forums and videos"
																	width="330"
									height="65"
														/>
					</a>

					
											<ul id="promos">
															<li>
									<span>
																					<a href="http://www.eurogamer.net/articles/2017-05-23-mario-kart-8-guide-tips-tricks-shortcuts-deluxe?utm_source=eurogamer&utm_medium=header-promo&utm_campaign=Mario+Kart+8+Deluxe+guide+tips+and+tricks">Mario Kart 8 Deluxe guide, tips and tricks</a>
																				<span>Characters, unlocks, shortcuts and more.</span>
									</span>
								</li>
															<li>
									<span>
																					<a href="http://www.eurogamer.net/articles/2017-05-23-persona-5-walkthrough-guide-tips-4249?utm_source=eurogamer&utm_medium=header-promo&utm_campaign=Persona+5+guide+and+walkthrough">Persona 5 guide and walkthrough</a>
																				<span>How to beat Palaces, ace quizzes and more.</span>
									</span>
								</li>
														<li id='boom-box'><div class="advertContainer" data-dfp-id='EGNET_BB' data-dfp-sizes='210x83' data-dfp-targeting='' id='div-ga-EGNET_BB' ></div></li>						</ul>

					
												<div id="account" class="out">
								
																	<div class="buttons">
										<a href="login.php" onclick="return SignIn();" class="tool"><i
													class="icon-user"></i> Sign in</a>
										<a href="register.php" class="tool"><i
													class="icon-plus"></i> Create an account</a>

										<div id="fb-login"></div>
										<script type="text/javascript">
											document.observe(
													"dom:loaded",
													function () {
														var Login = new Facebook(
																{
																	target: "fb-login",
																	translations: {
																		login: "Sign in via Facebook",
																		working: "Logging in&hellip;"
																	}
																}
														);
													}
											);
										</script>
									</div>
								
															<form id="login" class="login" method="post" action="login.php">
								<input type="hidden" name="useraction" value="login"/>
								<fieldset>
									<label>Username</label>
									<input id="login-username" name="username"/>
								</fieldset>

								<fieldset>
									<label>Password</label>
									<input type="password" name="password"/>
								</fieldset>

								<input type="submit" value="Log in"/>
								<a href="http://www.eurogamer.net/login.php" class="forgotten"
								   rel="nofollow">Forgotten your details?</a>

																	<img src="/img/EurogamerPage/popup.png" class="arrow"/>
															</form>
							
								
															</div>

							
					<div id="navigation" class="navigation-block">
						<ul>
																								<li>
										<a href="?type=review"
										   >
											<span>Reviews</span>
										</a>
									</li>
																																<li>
										<a href="?type=news"
										   >
											<span>News</span>
										</a>
									</li>
																																<li>
										<a href="recommended-games"
										   >
											<span>Recommended Games</span>
										</a>
									</li>
																																<li>
										<a href="http://www.youtube.com/eurogamer/"
										   >
											<span>Videos</span>
										</a>
									</li>
																																<li>
										<a href="?topic=digital_foundry"
										   >
											<span>Digital Foundry</span>
										</a>
									</li>
																																<li>
										<a href="releases.php"
										   >
											<span>Release Dates</span>
										</a>
									</li>
																																<li>
										<a href="?type=guide"
										   >
											<span>Guides</span>
										</a>
									</li>
																																<li>
										<a href="http://www.egx.net"
										   >
											<span>EGX</span>
										</a>
									</li>
																																<li>
										<a href="https://www.jelly.deals"
										   >
											<span>Deals</span>
										</a>
									</li>
																																<li>
										<a href="forum"
										   >
											<span>Forum</span>
										</a>
									</li>
																					</ul>

						
					</div>

											<div id="notifications">
							<img src="/img/EurogamerPage/popup.png" width="19" height="10"
								 class="arrow" alt=""/>

							<p class="init">
								Loading... hold tight!							</p>
						</div>
					
					
					
																									<form action="search.php" id="search" method="post">
								<input
										type="text"
										id="q"
										name="q"
										value=""
										placeholder="Search"
										x-webkit-speech
								/>
								<input type="submit" class="button" value="Go"/>
							</form>
																		
				</div>
			</div>

			<div id="page-wrapper">

																		
				<div 
					class="vwxoypxq" 
					data-yafa-img="https://bigboy.eurogamer.net/2017/sdkfjbgsdjbcjuh/jhfsgveyfdg.jpg" 
					data-yafa-click="http://bit.ly/2o6X8od" 
					style="display:none;width:1260px;height:250px;margin:0 auto;">
				</div>
										<div id="leaderboard" class="advert leaderboard">
								<div class="advertContainer" data-dfp-id='EGNET_LB_1' data-dfp-sizes='728x90, 960x160, 960x250, 970x250, 1260x110, 1260x160, 1260x200, 1260x250' data-dfp-targeting='position=atf' id='div-ga-EGNET_LB_1'  data-ghost-zone="3" ></div>							</div>
						
							
														
				<div id="page">
					<div id="content" class="">
							

			<div>
									<div class="followBar">
						<strong>Eurogamer.net</strong>
						<div class="social">
							
						<div class="facebook">
				<div class="fb-like" data-colorscheme="dark"
					 data-href="https://www.facebook.com/Eurogamer"
					 data-layout="button_count" data-show-faces="false" data-action="like" data-share="false"></div>
			</div>
		
						<div class="twitter">
				<a href="https://twitter.com/eurogamer"
				   class="twitter-follow-button" data-show-screen-name="false" data-show-count="true">Follow
					@eurogamer</a>
				<script>!function (d, s, id) {
						var js, fjs = d.getElementsByTagName(s)[0], p = /^http:/.test(d.location) ? 'http' : 'https';
						if (!d.getElementById(id)) {
							js = d.createElement(s);
							js.id = id;
							js.src = p + '://platform.twitter.com/widgets.js';
							fjs.parentNode.insertBefore(js, fjs);
						}
					}(document, 'script', 'twitter-wjs');</script>
			</div>
		
						<div class="youtube" style="margin-top: -2px;">
				<script async src="https://apis.google.com/js/platform.js"></script>
				<div
						class="g-ytsubscribe"
																			data-channelid="UCciKycgzURdymx-GRSY2_dA"
										></div>
			</div>
		
									</div>
					</div>
								
				<header>
												<ul class="breadcrumb">
					<li itemscope="" itemtype="http://data-vocabulary.org/Breadcrumb">
						<a href="http://www.eurogamer.net/" itemprop="url">
							<span itemprop="title">Home</span>
						</a>
					</li>
					<li itemscope="" itemtype="http://data-vocabulary.org/Breadcrumb">
						<a href="http://www.eurogamer.net/?type=news" itemprop="url">
							<span itemprop="title">News</span>
						</a>
					</li>
									</ul>

				<ul class="breadcrumb">
																		<li>			<span class="tag">Switch</span>
		</li>
											
									</ul>

										
					<h1>
													Unreal Engine now fully supports Nintendo Switch development														
					</h1>

											<p class="strapline" itemprop="summary">
							Approved developers receive the source code for free.						</p>
										
										
				</header>

								
				<div id="fragment-1">
					
					<article class="hd" data-permalink="http://www.eurogamer.net/articles/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development">

												
						
							<div class="social top">
											
			<div
				data-type="social-buttons"
				data-sites="facebook,twitter,google,reddit"
				data-url="http://www.eurogamer.net/articles/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development"
				data-title="Unreal Engine now fully supports Nintendo Switch development"
				data-lang="Share this:"
				data-device="hd"
				class="social-buttons"
			></div>

									</div>

							
						<p class="byline">			
							By <a href="author/647">Jeffrey Matulef</a>
		
							Published <span itemprop="datePublished" content="2017-05-24">24/05/2017</span>

													</p>

						<script>
							var localisations = {
								"zoomer-select-a-thumbnail": "Select a thumbnail to launch comparison tool"
							}
						</script>
	
											
		
		
			<section class="">
  <p>
 
Epic has teamed up with Nintendo to offer "fully-featured" Unreal Engine support to approved developers for free.</p>
  
  <div class="illustrationPreview  ">
    <img src="//images.eurogamer.net/2017/articles/1/9/0/2/5/6/2/149564129079.png/EG11/resize/300x-1/quality/80/format/jpg" data-uri="2017/articles/1/9/0/2/5/6/2/149564129079.png" width="300" alt="1" class="preview"/>
  </div>
  <p>
 
The previous version of Unreal Engine, 4.15, offered experimental support for Nintendo's new platform, but in this 4.16 update it contains the whole shebang.</p>
  
  <p>"Epic Games has teamed up with Nintendo to release the full Unreal Engine 4 source code for Nintendo Switch to approved developers for free!" Epic boasted in its <a href="https://www.unrealengine.com/en-US/blog/launch-your-game-on-the-nintendo-switch-with-unreal-engine-4-16" target="_blank">patch notes</a>. "After launching experimental support for Nintendo Switch development in February's Unreal Engine 4.15 release, Epic is proud to announce fully-featured native support for the popular platform in Unreal Engine 4.16."</p>
  
  <p>If you <a href="https://developer.nintendo.com/" target="_blank">apply to become an approved Nintendo Switch developer</a>, Epic will offer access to its UE4 Nintendo Switch forum for developers to talk amongst themselves about using the popular software with Nintendo's latest platform.</p>
  
</section>
		

	
														
	
				
								
									
						
						
						
						<div class="social bottom">
										
			<div
				data-type="social-buttons"
				data-sites="facebook,twitter,google,reddit"
				data-url="http://www.eurogamer.net/articles/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development"
				data-title="Unreal Engine now fully supports Nintendo Switch development"
				data-lang="Share this:"
				data-device="hd"
				class="social-buttons"
			></div>

								</div>
				
					</article>
	
								
				<ul id="sidebar">
					<li class="advert mpu">
																								<div class="advertContainer" data-dfp-id='EGNET_MPU_1' data-dfp-sizes='300x250' data-dfp-targeting='position=atf' id='div-ga-EGNET_MPU_1'  data-ghost-zone="1" ></div>					</li>

					
					
					
									<li><p class="affiliate_disclaimer"><em>Sometimes we include links to online retail stores. If you click on one and make a purchase we may receive a small commission. For more information, go <a href="http://www.eurogamer.net/policies.php?view=how-we-work#advertisingpolicy">here</a>.</em></p></li>
			
				</ul>

									</div>
			</div>

							
				<div id="fragment-2">
								<div class="article-footer">
							<div class="author">
				
				<h3>
					About <a href="author/647">Jeffrey Matulef</a>
				</h3>

				<img src="//images.eurogamer.net/2016/internalforum/users/jeffrey.matulef/1454628552.jpg/EG11/thumbnail/80x80/quality/90/format/jpg" class="picture" alt="Picture of Jeffrey."/>

				<p>
											Jeffrey Matulef is the best-dressed man in 1984. Based in Portland, OR he operates as Eurogamer's US news editor.									</p>

				
							<div id="extra-mpu">
				<div class="advertContainer" data-dfp-id='EGNET_MPU_2' data-dfp-sizes='300x250' data-dfp-targeting='position=btf' id='div-ga-EGNET_MPU_2'  data-ghost-zone="2" ></div>			</div>
					</div>
									<div class="related">

				

				
			<div id="recommendations">

				
					
						<div id="rcjsload_gam128"></div>
						<script type="text/javascript">
						(function() {
						function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}
						ad_block_test(function(is_blocked){
						var widget_id =47922;
						if (is_blocked === true) {
						widget_id =48115;
						}
						var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
						var rcel = document.createElement("script");
						rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
						rcel.type = 'text/javascript';
						rcel.src = "//trends.revcontent.com/serve.js.php?w="+widget_id+"&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth) +"&referer="+referer + '&is_blocked=' + is_blocked;
						rcel.async = true;
						var rcds = document.getElementById("rcjsload_gam128"); rcds.appendChild(rcel);
						});
						})();
						</script>

					
				
			</div>

		
				
				
							
				
									<a href="newsletters/preferences" class="newsletter-promo">
						<img
							src="/img/EurogamerPage/newsletter.png"
													/>
						<span>
							Subscribe to <strong>The Eurogamer.net Daily</strong>.
							The 10 most popular stories of the day, delivered at 5pm UK time. Never miss a thing.						</span>
					</a>
												</div>
					</div>
							
				</div>
				
							<div id="low-leaderboard">
				<div class="low-leaderboard advert">
					<div class="advertContainer" data-dfp-id='EGNET_LB_2' data-dfp-sizes='728x90' data-dfp-targeting='position=btf' id='div-ga-EGNET_LB_2' ></div>				</div>
			</div>
								
			<p class="comment-count">
				Comments									(2)
							</p>

			<div id="reply-box" >

				
					
													<div id="comments-login-prompt">
															<form id="comment-login" class="login" method="post" action="login.php">
								<input type="hidden" name="useraction" value="login"/>
								<fieldset>
									<label>Username</label>
									<input id="login-username" name="username"/>
								</fieldset>

								<fieldset>
									<label>Password</label>
									<input type="password" name="password"/>
								</fieldset>

								<input type="submit" value="Log in"/>
								<a href="http://www.eurogamer.net/login.php" class="forgotten"
								   rel="nofollow">Forgotten your details?</a>

															</form>
							
								<div class="other">
									<a href="register.php" class="tool new">Create an account</a>

									<p>OR</p>

									<div id="comment-fb-login"></div>
									<script type="text/javascript">
										document.observe(
											"dom:loaded",
											function()
											{
												var CommentLogin = new Facebook(
													{
														target: "comment-fb-login",
														anchor: "comments",
														translations: {
															login: "Sign in via Facebook",
															working: "Logging in&hellip;"
														}
													}
												);
											}
										);
									</script>

								</div>
							</div>
						
					
				
			</div>
								<div id="new-comments">

				
					<ul id="filters">

						
						<li>
										<ul class="horizontal-selector order" data-type="order">
				<li><strong>Order</strong></li>
				<li><a href="#" data-value="asc" class="on">Oldest</a></li>
				<li><a href="#" data-value="desc" >Newest</a></li>
				<li><a href="#" data-value="best" >Best</a></li>
				<li><a href="#" data-value="worst" >Worst</a></li>
			</ul>
								</li>

						<li>
							<ul class="horizontal-selector score" data-type="score">
								<li><strong>Score</strong></li>

																									<li><a href="#" data-value="-25" >-25</a></li>
																	<li><a href="#" data-value="-10" class="on">-10</a></li>
																	<li><a href="#" data-value="-1" >-1</a></li>
																	<li><a href="#" data-value="0" >0</a></li>
																	<li><a href="#" data-value="1" >+1</a></li>
																	<li><a href="#" data-value="10" >+10</a></li>
																	<li><a href="#" data-value="25" >+25</a></li>
															</ul>
						</li>

												
																					<li>
									
			
			<a
				href="https://www.jelly.deals/2017/05/23/nintendo-switch-accessories-and-deals-19/?utm_source=eurogamer&utm_medium=in-article-promo&utm_campaign=The+best+accessories+for+Switch"
				class="promotion
				comments"
			>
									<span class="details">
						The best accessories for Switch						<span>
							From Jelly Deals: essential accessories for Nintendo Switch.						</span>
					</span>
								<img src="https://cdn.gamer-network.net/2017/jamie.wallace/Screen-Shot-2017-03-15-at-13.05.52.png/EG11/thumbnail/300x260/quality/90/format/jpg" alt="The best accessories for Switch"/>
			</a>

											</li>
													
					</ul>
				
				<ul id="comments">
					<li class="loading">
						<span>Loading... hold tight!</span>
					</li>
				</ul>
			</div>

			<div id="quick-reply" class="popup"></div>

			<script type="text/javascript">
				// Global for use in Google Universal Event tracking
				var article = {
					"slug": "2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development",
					"type": "news",
																"platforms": "SWITCH",
										"author": "Jeffrey Matulef"
				};

				document.observe(
					"dom:loaded",
					function()
					{
						var comments = new Comments(
							{
								'aid': 1902562,
								'count': 2,
								'target': "comments",
								'version': "hd",
								'start': 0,
								'limit': 35,
								'filter': "all",
								'order': "asc",
								'avatars': "avatars-on",
								'score': -10,
								'isloggedin': "logged-out",
								'ismoderator': "",
								'lang': {
									'none': "There are no comments on this article. Why not post one?",
									'show': "Show",
									'reply': "Reply",
									'edit': "Edit",
									'hidden': "Low-scoring comment hidden.",
									'del': "Delete",
									'loading': "Loading... hold tight!",
									'delconfirm': "Are you sure you want to delete this comment?",
									'thanks': "Thanks!",
									"moderator": "Moderator",
									'ban': "Ban"
								},
								'article': article
							}
						);
					}
				);
			</script>

								
						
		    <script>
				document.observe("dom:loaded", function() {	
					var socialbuttons = new SocialButtons({});
				});				
		    </script>
			
						
								</div>

													<div id="skyscraper" class="advert"><div class="advertContainer" data-dfp-id='EGNET_HP' data-dfp-sizes='160x600, 300x600' data-dfp-targeting='position=atf' id='div-ga-EGNET_HP'  data-ghost-zone="5" ></div></div>
							
				</div>
			</div>

						<div id="footer">
				
					<ul>
						<li class="versions">
										<form method="post" action="/articles/2017-05-24-unreal-engine-now-fully-supports-nintendo-switch-development">
				<ul class="switcher">
					<li><button type="submit" name="version" value="mobile" >Mobile</button></li>
					<li><button type="submit" name="version" value="hd" class="on">Desktop</button></li>
				</ul>
			</form>
								</li>

						<li class="links">
															<a href="articles/the-eurogamer-staff" rel="nofollow">Staff</a>
														<a href="contact.php" rel="nofollow">Contact us</a>

										<a href="policies.php">Policy centre</a>		
		
							<a href="cookies.php" rel="nofollow">Cookies</a>

							<a href="http://www.gamer-network.net" rel="nofollow">Corporate site</a>
																				</li>

						<li class="social">
															<a href="//www.twitter.com/eurogamer" class="twitter" rel="nofollow"><i class="icon-twitter"></i> Twitter</a>
							
															<a href="https://www.facebook.com/Eurogamer" class="facebook" rel="nofollow"><i class="icon-facebook"></i> Facebook</a>
							
							
							<a href="rss.php" class="rss" rel="nofollow"><i class="icon-rss"></i> RSS</a>
						</li>

						<li class="sites">
							<a href="javascript:toggleSites();" class="tool uarrow current-site"><i class="icon-caret-up"></i> Gamer Network</a>
							<ul id="sites">
								<li>
									<ul>
										<li><a href="http://www.eurogamer.be" class="be">Eurogamer.be</a></li>
										<li><a href="http://www.eurogamer.cz" class="cz">Eurogamer.cz</a></li>
										<li><a href="http://www.eurogamer.de" class="de">Eurogamer.de</a></li>
										<li><a href="http://www.eurogamer.dk" class="dk">Eurogamer.dk</a></li>
										<li><a href="http://www.eurogamer.es" class="es">Eurogamer.es</a></li>
																				<li><a href="http://www.eurogamer.it" class="it">Eurogamer.it</a></li>
										<li><a href="http://www.eurogamer.net" class="net">Eurogamer.net</a></li>
										<li><a href="http://www.eurogamer.nl" class="nl">Eurogamer.nl</a></li>
										<li><a href="http://www.eurogamer.pl" class="pl">Eurogamer.pl</a></li>
										<li><a href="http://www.eurogamer.pt" class="pt">Eurogamer.pt</a></li>
										<li><a href="http://www.eurogamer.se" class="se">Eurogamer.se</a></li>
										<li><a href="http://www.brasilgamer.com.br" class="br">Brasilgamer.com.br</a></li>
									</ul>
								</li>
								<li>
									<ul>
										<li><a href="http://www.gamesindustry.biz">GamesIndustry.biz</a></li>
										<li><a href="http://www.rockpapershotgun.com">Rock, Paper, Shotgun</a></li>
										<li><a href="http://www.vg247.com">VG247.com</a></li>
										<li><a href="https://www.vg247.it">VG247.it</a></li>
										<li><a href="https://tr.vg247.com">VG247 T&uuml;rkiye</a></li>
										<li><a href="http://www.nintendolife.com">NintendoLife.com</a></li>
										<li><a href="http://www.usgamer.net">USgamer.net</a></li>
										<li><a href="http://hearthstone.metabomb.net">Metabomb: Hearthstone Guides</a></li>
										<li><a href="http://hots.metabomb.net">Metabomb: Heroes of the Storm Guides</a></li>
										<li><a href="http://overwatch.metabomb.net">Metabomb: Overwatch Guides</a></li>
										<li><a href="http://wow.metabomb.net">Metabomb: WOW Legion Guides</a></li>
										<li><a href="https://www.gamersedition.com">Gamer's Edition</a></li>
										<li><a href="https://www.jelly.deals">Jelly Deals</a></li>
									</ul>
								</li>
								<li class="arrow"><img src="/img/EurogamerPage/site-arrow.png" width="20" height="15" alt=""/></li>
							</ul>
						</li>

													<li class="hosted-by">
								Hosted by <a href="http://dx.net/" rel="nofollow">dx.net</a>
							</li>
											</ul>
							</div>
				</div>

										<script type="text/javascript">
				document.observe("dom:loaded", function () {
					checkLanguage({
						site: 1,
						sites: {
															2: {
									www: "http://www.eurogamer.de/",
									exists: "Kennst du Eurogamer.de?",
									cta: "Hier klicken, um zu Eurogamer.de zu gelangen!"
								},
															4: {
									www: "http://www.eurogamer.es/",
									exists: "&iquest;Conoces Eurogamer.es?",
									cta: "Haz click aqu&iacute; para visitar Eurogamer.es"
								},
															5: {
									www: "http://www.eurogamer.it/",
									exists: "Sapevi di Eurogamer.it?",
									cta: "Clicca qu&igrave; per visitare Eurogamer.it!"
								},
															10: {
									www: "http://www.eurogamer.cz/",
									exists: "V&iacute;te o Eurogamer.cz?",
									cta: "Klikn&#283;te zde pro n&aacute;v&scaron;t&#283;vu Eurogamer.cz!"
								},
															13: {
									www: "http://www.eurogamer.pl/",
									exists: "Czy wiesz, &#380;e Eurogamer jest dost&#281;pny po polsku?",
									cta: "Kliknij tutaj, by przej&#347;&#263; na Eurogamer.pl!"
								},
															7: {
									www: "http://www.eurogamer.nl/",
									exists: "Had je al gehoord van Eurogamer.nl?",
									cta: "Klik hier om Eurogamer.nl te bezoeken!"
								},
															6: {
									www: "http://www.eurogamer.se/",
									exists: "Visste du att Eurogamer finns i Sverige?",
									cta: "Bes&ouml;k Eurogamer Sverige genom att klicka h&auml;r!"
								},
														15: {
								www: "http://www.usgamer.net",
								exists: "Have you heard about USgamer.net? It covers the best in video gaming from an American perspective.",
								cta: "Click here to visit!"
							}
						}
					})
				});
			</script>
						
		<div class="advertContainer" data-dfp-id='EGNET_POPUP' data-dfp-sizes='1x1' data-dfp-targeting='' id='div-ga-EGNET_POPUP' ></div><script type='text/javascript'>
						function yafaIt() {
							
							var yafaList=document.querySelectorAll('[data-yafa-click]');
							
							for (var i=0; i < yafaList.length; i++) {
								var yafa=yafaList[i];
								var yafa_click=yafa.getAttribute('data-yafa-click');
								
								
								j('#page-wrapper').each(function () {
								this.style.setProperty( 'background', 'url('+yafa.getAttribute('data-yafa-img')+') white no-repeat 50% 0', 'important' );
								this.style.setProperty( 'padding-top', '200px', 'important' );
								});
								j('html').bind('mousemove', function(e) {
									if( (e.target==j('#page-wrapper')[0]) && (e.pageY <=1200 ) ) {
											j('html').css({ 'cursor' :'pointer' });
									} else {
											j('html').css({ 'cursor' :'auto' });
									}
								});
								j('html').bind('click', function (e) { 
									if( (e.target==j('#page-wrapper')[0]) && (e.pageY <=1200 ) ) {
										window.open(yafa_click,'_top');
									}
								});
								yafa.removeAttribute('data-yafa-img');
								yafa.removeAttribute('data-yafa-click');
							}
							j('.advertContainer').hide();
							j('#skyscraper').hide();
							j('#leaderboard').hide();
						}
					</script>
					<script type='text/javascript'>						j(document).ready(function() {							if(j('#content header').length) {
								j('#skyscraper').css({'margin-top' :j('#content header').height() + 'px'});
							}
					
					if(j('#prod-buy').length > 0) {
				j('#sidebar .games').after('<li id="sidebar_amazon"></li>');
				j('#sidebar_amazon').append(j('#prod-buy'));
				j('#prod-buy').show();
			}
				
					var adblock_message='';
					var custom_variables={};
					custom_variables['source']='article';
					custom_variables['version']='hd';
			custom_variables['tags']=["switch","news"];
				adblock_message='';
				
				
				var lazyloading=true;
 
				function lazyloadAds() {
				lazy_mpus=j('.mpu .lazyload').filter(':visible');
				if(lazy_mpus.length==0) {
					lazyloading=false; 
					clearInterval(lazyloadInterval);
				} else {
				for ( var i=0; i < lazy_mpus.length; i++ ) {
					mpu_pos=j(lazy_mpus[i])[0].getBoundingClientRect();
					if(mpu_pos['top'] < 1300 && lazyloading==true){
							j(lazy_mpus[i]).getDFPads({'custom_variables' :custom_variables}); 
							j(lazy_mpus[i]).removeClass('lazyload').addClass('lazyloaded'); 
				}
				}
				}
				}				if(custom_variables['version']=='mobile' && custom_variables['source']=='article'){
				lazy_mpus_check=j('.mpu .lazyload').filter(':visible');
				if(lazy_mpus_check.length > 0) {
					var lazyloadInterval=setInterval(lazyloadAds, 300);
				}
				}				try {
					j('.advertContainer').getDFPads({'custom_variables' :custom_variables, 'adblock_message' :adblock_message, 'acceptable_ads_show' :true});
				} catch(e) {
					yafaIt();
				}
			});
					</script>
			
				<script type="text/javascript">
			document.observe("dom:loaded", function () {
				var LazyHeadlines = new LazyLoad(
						{
							target: "#content div.content img.headline",
							placeholder: "img/padding.gif"
						}
				);

				var LazyAvatars = new LazyLoad(
						{
							target: "img.avatar",
							placeholder: "img/EurogamerPage/who.png"
						}
				);

				var LazyPackshots = new LazyLoad(
						{
							target: "img.packshot",
							placeholder: "img/EurogamerPage/packshot.png"
						}
				);
			});
		</script>
	
		<script type="application/ld+json">
				{  "@context" : "http://schema.org",
				   "@type" : "WebSite",
				   "name" : "Eurogamer.net",
				   "url" : "http://www.eurogamer.net/"
				}

		</script>

				<script type="text/javascript">
			document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
		</script>
		<script type="text/javascript">
			COMSCORE.beacon({c1: 2, c2: 8518622, c3: "", c4: "", c5: "", c6: "", c15: ""});
		</script>
		<noscript>
			<img src="//b.scorecardresearch.com/p?c1=2&c2=8518622&c3=&c4=&c5=&c6=&c15=&cj=1"/>
		</noscript>

		<!-- Facebook Pixel Code -->
		<script>
			!function (f, b, e, v, n, t, s) {
				if (f.fbq)return;
				n = f.fbq = function () {
					n.callMethod ?
							n.callMethod.apply(n, arguments) : n.queue.push(arguments)
				};
				if (!f._fbq)f._fbq = n;
				n.push = n;
				n.loaded = !0;
				n.version = '2.0';
				n.queue = [];
				t = b.createElement(e);
				t.async = !0;
				t.src = v;
				s = b.getElementsByTagName(e)[0];
				s.parentNode.insertBefore(t, s)
			}(window,
					document, 'script', '//connect.facebook.net/en_US/fbevents.js');

			fbq('init', '897415313645265');
			fbq('track', 'PageView');
		</script>
		<noscript><img height="1" width="1" style="display:none"
					   src="https://www.facebook.com/tr?id=897415313645265&ev=PageView&noscript=1"
			/></noscript>
		<!-- End Facebook Pixel Code -->

						<script type="text/javascript"
				src="//s.skimresources.com/js/87431X1540261.skimlinks.js"></script>
	
				
				<script type='text/javascript'>
			var _sf_async_config = _sf_async_config || {};
			/** CONFIGURATION START **/
			_sf_async_config.sections = 'news,SWITCH,hd';
						_sf_async_config.authors = 'Jeffrey Matulef';
						_sf_async_config.type = 'news';
			/** CONFIGURATION END **/
			(function () {
				function loadChartbeat() {
					window._sf_endpt = (new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');

					document.body.appendChild(e);
				}

				var oldonload = window.onload;
				window.onload = (typeof window.onload != 'function') ?
						loadChartbeat : function () {
					oldonload();
					loadChartbeat();
				};
			})();
		</script>
				<script>
			function mormontLoaded () {

						mormont('configure', 'property', 'eurogamer');
			mormont('set', 'section', 'article');
			if (window.location.pathname.match('^/profile')) {
				mormont('set', 'section', 'community');
			}
			if (window.location.pathname.match('^/inbox')) {
				mormont('set', 'section', 'user');
			}
			mormont('set', 'language', 'en');
							mormont('set', 'platforms', ["switch"]);
																mormont('set', 'published', '2017-05-24T16:53:00');
				mormont('set', 'article_type', 'news');
										mormont('set', 'author', "Jeffrey Matulef");
						mormont('send', 'pageview');

											mormont('configure', 'label', ['Hey! Listen','Would you kindly look at this too?','It\'s dangerous to go alone! Read this','Khajiit has article, if you have click','Here\'s a thing','JASON!','Continue?','Notice me Senpai','Stealth Destiny article','Our favourite articles on the citadel',]);
				mormont('configure', 'recommendations_site', 'www.eurogamer.net');
				mormont('configure', 'selector', 'article');
				mormont('configure', 'render_recommendations', true);
									mormont('configure', 'max_rec_links', 6);
					mormont('configure', 'max_containers', 3);
								
									mormont('fetchRecommendations');
										};
		</script>
		<script src="//cdn.gamer-network.net/2017/scripts/mormont/v2.9/mormont.js" async onload="mormontLoaded()"></script>

				
			</body>
</html>
		